Installation Guide:

Step 1 Downloading the picture book: 

Please visit the picture book download page to download the project. Make sure to download the binary and source version instead of the source only version. 

Step 2 Downloading the JRE: 

In order to install and run the picture book Java Runtime Environment is needed. If JRE is already installed please make sure the version is later than 1.4.1. Execute the following command in the command-line tool to display the version number: 

java -version

If 1.4.1 or later is installed please skip to step 3. Visit the JVM download website for detailed information and the download. If the program is to be used on a UNIX/LINUX machine please configure the necessary environment variables for the JRE. 

Step 3 Installing picture book: 

Unzip the zip archive that was downloaded from the picture book download page in step 1 into a new folder/directory. 

Step 4 Starting the application: 

Open directory which the archive is unzipped to. Open the PictureBookDemo folder. If Microsoft Windows environment is used execute runMe.bat. Under Unix/linux environments execute run.sh. If error is encountered in this step there might be incorrect environment or system configuration(s). Please consult the sun web site for support. 

Notes on running the picture book: 

Image operations such as scaling and loading are very costly for the JVM in terms of process time and memory allocation. In order for Picture Book to utilize these operations, custom virtual memory allocation is required. It is suggested that the Java VM memory size should be configured to hold minimum of 128mb and maximum of 512mb. These settings can be configured by using the following command: 

java -cp PictureBook.jar;jdom.jar;. -Xms128m -Xmx512m com.al.picturebook.PictureBook 

If these guidelines are not followed, certain operation in picture book might take an abnormal amount of process time. Even out of memory exception could be thrown at times. Note: The batch file and shell script that is included in the demo are already configured with these settings. 

System requirements: 

Picture book requires the JVM (JRE 1.4.1 or later) in order to operate. The right mouse clicked is used for some of the editing operations. Mac users would have to use an emulated key for these operations. 

General Operations: 

Creating collection: 

In picture book, a collection is defined as a list of image nodes. To create a collection, select the new Collection option in the File menu as shown in the following figure: 



After selecting new Collection a small panel will pop up to prompt for the collection name and its contents. Type a valid name for the collection in the name field and click on the include Directory and/or include files... buttons to add image nodes. (For detailed instructions of adding image nodes consult the Collection Management section.) Click on the OK button when the user wishes to complete the process. 
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Figure 3 

Opening list file: 

Collections can be saved to and loaded from list files. The list files that are used by picture book are in xml format. To open a file, click on the Open List File option as shown in Figure 2. A file browser will pop up to prompt for a specific file to open. After selecting the correct file click ok. The file will be loaded into picture book. Once a list file is opened all of its contents will be loaded into picture book. If the same collection name is being used by one of the existing collections picture book will prompt for a unique name for the new collection. 

Saving collections:

The collections of a picture book can be saved to a list file. The user can save the collections by selecting the Save Lists option from the File menu. (See Figure 2) By default the collections are saved in a list file named default.xml in the working directory of the program. Use the save list as option in the File menu to save the collections in a file named other than defualt.xml. 

Exiting picture book:

Click on the exit option in the File menu to exit the picture book. Upon exit an option panel will appear to ask if the user wants to save the changes that have been made to the collections. (See Figure 4) 
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Figure 4 

Navigation & Display:

Navigating and display are made to be one of the easiest things to learn in picture book. There are many ways to navigate through the collections including using the tool bar, the side panel and the thumbnail panel. The image that is displayed in the main panel is called the current image. In the thumbnail panel the thumbnail view of the current image is highlighted with light blue. (See Figure 1 for detailed illustration.)

Navigating with the tool bar: 

There is a set of four buttons in the middle of the tool Bar. (See Figure 1) [image: image3.jpg]
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These buttons can be used to navigate through the collections of image nodes. When [image: image7.jpg]


is pressed the next picture in the list becomes the current image which means that the main panel will display a full view of it and it's thumbnail will be highlighted in the thumbnail panel. When [image: image8.jpg]


is pressed the previous picture becomes the current picture. Use [image: image9.jpg]


and [image: image10.jpg]


to navigate through sections of images nodes.

Navigating with the explorer(side panel): 

A user can navigate through the image collections by clicking on image nodes in the explorer of the side panel. If image nodes are selected with single clicks the image would be only displayed in the properties panel instead of the main panel. (For instruction on opening the properties panel please consult the Annotation and properties window section of this manual.) If the user chooses the picture nodes by double clicking then the selected picture will become the current picture. The different results of single clicking and double clicking are shown below. 
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Figure 5 single clicking 
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Figure 6 double clicking 

Navigating with the thumbnail panel:

The thumbnail panel has limited functions as to navigating the image nodes. It can only navigate within the rage of the visible thumbnails in the panel. Click on the thumbnails to show the images in the main panel. 

Switching collections:

Collections can be switched by double clicking the image nodes in the explorer. If the picture book is switched to use a collection the tool bar buttons can only navigate through the images nodes of that specific collections. The picture book has to be switched to a collection in order to edit some of its properties. For instructions on editing these properties please consult the Collection Management section of this manual. 

Hiding the thumbnail panel:

The thumbnail panel can be hidden to give a better perspective of the image in the main panel. Press the [image: image13.jpg]


button to hide the thumbnail panel. To undo this change press the [image: image14.jpg]


button. Both of the buttons can be found on the left side of the tool bar. 

Resizing views: 

By default, the view of the image in the main panel is resized to fit the dimensions of the panel. This setting can be adjusted by the drop down list to the right of the help menu. (See Figure 7) Press the arrow button to display a collection of different resizing settings. After selecting the correct setting the picture book will resize the picture accordingly and display it in the main panel. Picture book only supports fixed proportioned resizing. 
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Figure 7
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Figure 8


Full-Screen & Slide-Show

Picture book can be changed into Full-Screen or Slide-Show modes by using the View menu. Once picture book enters the Full-Screen mode a small exit button will be displayed on the upper-left corner. Click on this button to exit the Full-Screen mode. It takes similar procedure to exit the Slide-Show mode. (See below for detailed illustration) 
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Figure 9 view menu 
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Figure 10 exit button 


Collection Management:

The collections of picture book can be managed by using the explorer and the menus. Image nodes can be removed from and added to any collection. Take note that making these changes will not affect the actual image files that is saved on the hard disk. 

Adding image nodes: 

The File menu can be used to add image nodes to a collection. First the user has to navigate to the specific image collection of which the image files are to be added. (For instructions on navigation please consult the navigation & display section of this manual). Once the correct collection is chosen, click on the Include File(s) option in the File menu. (See figure 2). A file browser will then appear to ask for the specific file(s) of which the user wishes to add. Multiple files can be selected by clicking on the specific files while holding the ALT key. Picture book is also capable of adding a whole directory of image files. In order to include a directory of image files choose the Include Directory option in the File menu.(See Figure 2) A file browser that is similar to the include file browser will appear prompting for the specific directory. Note: multiple selections of directories are not allowed. Detailed illustrations of the File and directory browsers are shown below. 
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Figure 11 selecting files 
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Figure 12 selecting directory 

Removing image nodes:

To remove image nodes from a collection, select them first on the side panel. (See navigation & display section for instruction on selecting images) Multiple selections using the ALT key is allowed. Right click on the image nodes to display the editing options. Note: Mac users would have to use an emulation key for the right mouse click. Select the Delete from list option to delete the selected image node(s) from the collection. Note: By selecting this option only the image node(s) will be removed form the list. The actual image file will still exist in the hard disk. Detailed illustration of the editing option menu is shown below. 
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Figure 13

Copying and moving image nodes: 

The editing option menu shown in figure 15 can also be used for copying and moving image nodes. To copy an image node, click on the Copy To... option. A sub menu containing a list of existing collections plus an option to create a new collection with the selected file(s) will be displayed. (See figure 14). Choose the destination where the image nodes are to be copied. If the [create new collection] option is selected then an option panel with a name filed will appear to prompt for the new collection's name. Note: Collection names must be unique. Moving image nodes takes similar procedures as copying. 
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Figure 14

Removing and Renaming Collection(s): 

It is fairly easy to remove or rename a collection in picture book. Right click on one of the collection nodes and menu selections will appear as shown below. Select Unmount Collection to remove the collection from picture book. If rename Collection is selected an option panel will then appear to prompt for the new name. 
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Figure 15 

Annotation and the properties window:
Annotation is one of most distinctive features of picture book as an image organizer. By default every image node in the list has one annotation which is its name. This annotation can be edited but it cannot be deleted. The annotation feature provides ways to add comments to images for easy management. Annotations can be added, removed, edited and searched by using the properties panel and the edit menu. The properties panel can be displayed by clicking on the properties tab on the side panel. (See Figure 16) This panel can also be undocked by clicking the properties window button on the tool bar. 

	[image: image24.jpg]



Figure 16
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Figure 17 


Adding annotation(s): 

To add an annotation press the add button in the property panel. (See figure 18) An option panel will then appear to prompt for the name and the contents of the annotation. Once the information is entered correctly press Add to add the annotation. 
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Figure 18
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Figure 19


Editing annotation(s): 

Before editing the annotation choose the correct annotation in the small drop down list as shown above. After choosing the correct annotation, press the edit button to bring up an option panel to edit the contents of the specific annotation. (See Figure below) 
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Figure 20

Removing annotation(s): 

Deleting annotations is a fairly easy task. Choose the correct annotation in the drop down list and press the delete button in order to remove an annotation form the selected picture. (See figure 18) 

Searching by annotations: 

Every picture node is searchable by its annotation(s). Since the name of the file is included as one of the annotations searching by name is also made possible by this feature. To search for an image node, select the search option in the edit menu. An option panel will then appear with an empty field. Type the string for query and press ok. The search results will be place in a new collection named search results. (See detailed illustration below) 
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Figure 21 
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Figure 22 
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Figure 23 


